ZTE Avid Trio's home, and recents softkeys stopped working

I woke up this morning and turned on my phone to find that my home key, recents key and the pull down shade at the top of the screen had stopped working, also I'm not getting notifications anymore.They were working fine as early as 1:30 am last night. I checked my email then turned the phone off and connected it to my charger, my phone at the time was at 67%. I woke up this morning at 6:30am and disconnected the charger and turned the phone on and the keys didn't work. I have done some research on this and it seems like the only option i found was to download an app or do a factory reset, which may or may not work. Is there any other way to get the keys to work? And if I do a factory reset, will I lose all the data on my SD card which i have set as internal storage, or can i just remove the SD card before doing the factory reset? Also can I root this phone and if so would I be able to fix it by rooting it and doing something? I am running Android marshmallow 6.0.1.
An update, i just did an update of android from my provider and it didn't solve the issue, so if a system update didn't work then would a factory reset work, i'm thinking it wouldn't, but i'm not sure?

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by lesly.schuster
4 hours ago
Last post by federico.osinski
2 hours ago
Last post by joanne.baumbach
1 hour ago
Last post by halvorson.kurt
3 hours ago
Start up message
Started by jrice
Last post by considine.liana
43 minutes ago
Last post by kieran.okon
1 hour ago
Last post by hoppe.carli
1 hour ago
Last post by ukilback
4 hours ago
Last post by rae69
2 hours ago
Last post by iondricka
22 minutes ago