After Rebooting My Phone I Have No Network

EWhen I reboot my phone instead of going through the routine of SIM lock PIN then phone lock PIN, it just goes straight to the phone lock with no network connection.

This firstly occurred at work today when distractedly I ended up in "Safe mode", which doesn't work for me in any case as there's a bug or whatever somewhere which is by the by. So after rebooting a warning triangle and exclamation mark was showing in the status bar where it said...."Your selected network (3) is not available", 3 being my network in the UK. I did the obvious: removed the SIM, gave it a wipe, remounted it and hey...network back!

I was a little concerned that perhaps the pins in the SIM card housing may be faulty so to check I rebooted my phone this evening after work with exactly the same result and the same solution. Totally bizarre, so anyone have any ideas?

Thanks in advance,

Malc.

Posted via Android Central App on my XT1032

Edit: Forgot to add I have wiped the cache.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by romaguera.burdette
3 hours ago
Last post by glover.mattie
4 hours ago
Last post by koss.maybell
3 hours ago
Last post by gussie87
46 minutes ago
Last post by grogahn
45 minutes ago
Last post by dorothea80
4 hours ago
Last post by fshanahan
16 minutes ago
Last post by nash42
1 hour ago
Last post by sanford.leonardo
1 hour ago
Last post by tremblay.joel
22 minutes ago
Last post by reyna.yundt
2 hours ago
Last post by rodrick91
2 hours ago
Last post by tremblay.norberto
1 hour ago
Last post by monserrat17
55 minutes ago
Last post by armando.lockman
1 hour ago