Asus Zenfone max Z010D stuck on bootloop showing error: invalid boot image

the device was left unused for the last six months but when i tried to turn it on yesterday it turned on with an error message and the asus logo. The error message was error: invalid boot image. I downloaded the latest ROM version from asus offiicial site and tried to flash it through sd card and recovery mode but unfortunately it got stuck on 23% and eventually failed. Next time i tried to flash the room again but this tim it came with another error which is E: Can't mount/cache/recovery/last_log(invalid argument). What i did next is... i tried to flash it using adb sideload but then the error keeps on coming. When i tried the fastboot mode there was another error which is error: oem unlocking is not possible (i tried to unlock the oem because without that flashing is not possible from fastboot). The thing you should note is that :
1. debugger mode is not on
2. OEM lock is not on
3. I cant boot past the bootloop/error message which means i cant set usb debugging or oem unlock on
4. i have tried every other procdure from wipe cache/format data etc. what have i missed?

help me out.... its my crush's mobile phone.. hope you understand how much important is it to repair the device.

here are some pics please help me out
ibb(.)co/cohV5z
ibb(.)co/kyb1Ce
ibb(.)co/gGJEXe
ibb(.)co/eLnV5z
ibb(.)co/k8wOQz

remove the ( ) from (.) to go to the link of the images

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by bernier.katelyn
3 hours ago
Last post by ervin68
3 hours ago
Last post by martina02
4 hours ago
Beep n Go
Started by rdavis
Last post by thurman.leuschke
4 hours ago
Last post by dickinson.paula
3 hours ago
Last post by crist.krystel
2 hours ago
Last post by erick.raynor
2 hours ago
Last post by elda49
42 minutes ago