[Q] About building ROMs for a higher version of Android

So, I'm building my very first LineageOS 15.1 ROM with the files I got from Stock Android 7.1.1. I don't have a phone to test it yet, so I decided to collect some info to improve it.
My device has a chipset MSM8937. The latest Android version was 7.1.1 by the time I started to mess with the Lineage, now they released 8.1 for the device.
1- If I want to build LOS16.0, am I supposed to replace the proprietary files with a device with LineageOS 16 and same chipset's proprietary files?
2- What kind of changes I have to make when using files of a lower Android version to make a higher Android version?

Thanks in advance.

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by scotty85
14 minutes ago
Last post by eleanora72
2 hours ago
Last post by brennan.lang
2 hours ago
Last post by jarred.bashirian
3 hours ago
Last post by hosea49
2 hours ago
Last post by dicki.brooks
1 hour ago
Last post by zconsidine
2 hours ago
Last post by eden.deckow
3 hours ago
Last post by wbecker
4 hours ago
Last post by lukas83
3 hours ago