Moto x2 shuts down after turning it on, help?

I replaced a part on my moto x 2nd gen a while back, all went fine but I didn't use the phone for a month. Today I turn it on, it shows me the motorola logo, then shuts down without anything else.

I noticed it takes longer for it to respond after pressing and holding the power button because normally the screen would light up faster.

Sometimes I kept seeing the battery logo, then it shutdown, some other times I saw a green led. I assumed the battery was discharged so I decided to recharge it. I tried everything I could find on google:
-letting it charge overnight
-switch to a charger with a higher amperage (quickcharge on my powerbank)
-change chargers in general
-go to fast boot menu and let it charge

I don't know what the issue is. What's bothering me is when I go to fastboot menu and choose normal startup, shows the motorola logo and shuts down, when I choose recovery it does the same.

Any thoughts? I simply want the phone to turn on :/

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

CWM recovery
Started by ohoppe
Last post by gorn
4 hours ago
Last post by alize.gorczany
2 hours ago
Last post by hamill.yvonne
1 hour ago
Last post by drew93
3 hours ago
Last post by jessica42
4 hours ago
Last post by bschoen
4 hours ago
droid ultra
Started by rice.ole
Last post by esmeralda.ebert
18 minutes ago
Last post by grayson.morissette
3 hours ago
Last post by pnitzsche
48 minutes ago
Last post by jast.cleta
15 minutes ago
mobile data
Started by darlene28
Last post by else.senger
4 hours ago
Last post by trice
4 hours ago