Android pie on moto g 6

Hi Developers.
Greetings
I have been trying to install android 9 on my moto g6. My mobile architecture is ARM. Model is XT1925-13 bought from Amzon in India.
I successfully rooted my mobile and present OS is android 8. I have installed Magisk and TWRP. A week back i was able to install android Pie (Image. secuflag) and installed Gapps. arm .9 aroma package. but when i booted the mobile i failed to dial any call and failed to receive any call. i was getting error warning as Google play service error and google pixel could not be installed. How to fix it?.

The recent second problem is when i tried to install Pie. 9 on my mobile, the installation goes well but i when i try to install Gapps it says error 64 wrong architecture. i downladed the Gapps from the gapps .org and correct variant, i did not make any error in identifying and downloading the gapps. Jow to fix it?.
every time i try to install i clean the datas by going to twrp both factory reset and formate data. Even i tried advance clean and file format change.

Regards
nrchandar0100

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by runolfsson.camille
13 minutes ago
Last post by chaz41
3 hours ago
Last post by bayer.kamille
26 minutes ago
Last post by lyundt
40 minutes ago
Sync music
Started by nolan.dora
Last post by sedrick39
1 hour ago
Last post by kirlin.percy
2 hours ago
Last post by groberts
1 hour ago
Last post by cparisian
1 hour ago
Last post by akeem.carroll
3 hours ago