[Q] root access via mempodroid doesn't work anymore on Acer A511?

Hi,

I am new to this forum that is the reason for asking this question in this section but I have a experience in scripting, rooting, modding and (un-) bricking different hardware.

Ok, I am a new owner of a Acer A511 (it's like A510 but with 3G) and tried to root it like this description in this .

If I start the script runit-win.bat I am getting the following output.

Code:
Full root for A100, A500 and A510 ICS. Simple method. Device connected. Preparation for executing of the main script. push: tools/su -> /data/local/tmp/su push: tools/runit.sh -> /data/local/tmp/runit.sh push: tools/mount.sh -> /data/local/tmp/mount.sh push: tools/mempodroid -> /data/local/tmp/mempodroid push: tools/getroot.sh -> /data/local/tmp/getroot.sh push: tools/delroot.sh -> /data/local/tmp/delroot.sh push: tools/busybox.sh -> /data/local/tmp/busybox.sh push: tools/busybox -> /data/local/tmp/busybox 8 files pushed. 0 files skipped. 1044 KB/s (840355 bytes in 0.786s) 1174 KB/s (37273 bytes in 0.031s) - Preparation is finished. - Executing of the main script. remote object '/system/bin/su' does not exist The file "su" isn't created! - Not getting root! :( - Error! - Press any key.

Ok, I took a look to the scripts and I think the command "/data/local/tmp/mempodroid 0xd9f0 0xaf47 sh /data/local/tmp/getroot.sh" doesn't work. I opened a shell "(Windows Shell) adb shell" and executed the command "/data/local/tmp/mempodroid 0xd9f0 0xaf47 sh" and also the command "/data/local/tmp/mempodroid 0xaf47 sh" for getting a single root shell but it doesn't work. If I try to do a reboot via shell I am getting the message "reboot: Operation not permitted".

Also I have deactivated the pre installed Anti Virus (Mc Affee) on tablet. I have no idea anymore but it seems to me that the exploit mempodroid doesnt't work for me or my FW version.
<edit on>
With my HTC Desire HD I had to unlock the bootloader and to install the Clockwork Mod. I understand the for rooting the Acer A5xx that this isn't a prerequisite. Is this correct?
<edit off>

Informations
HW: Acer A511
Acer APN-Version: 1.203-1(t)
Flex-Version: Acer_AV041_A511_1.028.00_EMEA_DE

Do you have some ideas more or can you move this problem to the correct thread so I am nearer to solve the problem!?

Best regards

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by zieme.wiley
3 hours ago
Last post by linnie.blanda
1 hour ago
Last post by dahlia80
3 hours ago
Last post by valerie36
12 minutes ago
Last post by beverly.hermiston
4 hours ago
Last post by gottlieb.skye
3 hours ago
Last post by zola12
1 hour ago
Last post by foster58
3 hours ago
Last post by dkertzmann
1 hour ago
Last post by bettye52
17 minutes ago
Last post by kaley.schoen
3 hours ago
Last post by kunde.orrin
51 minutes ago