How to Fix Unfortunately Google Play Services Has Stopped Problem on my Nexus 7 (2012)?

Hello,

I have a 2012 Nexus 7 (unrooted, running stock android). Until about a week ago everything was fine, but then errors started popping up. In particular I would be told that some app had stopped working and also receive other error messages saying that "unfortunately google play services has stopped"; this latter error began popping up more and more. After some googling I found that this was a somewhat common problem (or common enough to have multiple threads for different devices here and elsewhere online) and some potential means for resolving them. Unfortunately, nothing I tried succeeded in stopping this problem (i.e. rebooting the device; rebooting the device and clearing the cache via system recovery; clearing the cache and data from google play). I finally did a factory reset on the device. When it finished and I started the device up again and was prompted to sign into my account I was immediately hit with warnings that Google Drive, Email, and Gmail services had stopped. I sign in and I start getting the google service error again. Google Chrome also fails to work at all now (prior to the reset it would work, now it starts up and almost immediately shuts down; gmail also does not work, although google maps does).

I have also tried shutting off Google Sync on my account (since the reset) as another thread suggested that might be the problem, but shutting it off does not help ...although something does appear to be wrong with sync - when I go to my google account it says "sync error" under my account name and the message "sync is currently experiencing problems. it will be back shortly" is provided at the bottom of the screen. Clicking on the account I see all the services that are supposed to sync; currently they are all checked and everything appears to be synced, i.e. they all say 'last synced' with a period of a few minutes ago, with the sole exception of "people details" where there is an error symbol. Unchecking people details does not resolve the issue. that google sync may nevertheless be at issue is also suggested by a threat on justanswer that I found on this problem where someone with the same error posted about it someone suggests that it is likely a google server issue with the solution being to get google to shift the account to a new server. (this may be particularly relevant since I did recently move overseas, although this problem only emerged several weeks after that)...but I do not know how to check that or resolve such an issue if it were the problem.

I also an android based phone , but the problem has not really shown up there (although I did notice the same google service error the other day, it appears to have been an isolated issue).

Does anybody have any insight into how this issue can be resolved?

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by lenny13
1 hour ago
Last post by hortiz
3 hours ago
Last post by tara54
4 hours ago
Last post by schmidt.jordy
4 hours ago
Last post by asa80
3 hours ago
Last post by eduardo.ryan
3 hours ago
Last post by hansen.kassandra
39 minutes ago
Last post by senger.thora
3 hours ago
Last post by johnnie89
3 hours ago
Last post by treichert
2 hours ago
Last post by jwilderman
4 hours ago
Last post by aosinski
1 hour ago