Galaxy S 3 Failed to mount /system - How to get my data?

Hi there,

my battery was low (3%) and i connected my S3 to my charging cable. After that i started spotify. When I wanted to show a friend, who was in a different room, a title of a song, the screen froze and i couldnt do anything (On-/off-button didn't react, touchscreen didnt react)
I took out the battery and put it back in to restart the phone.

Since then the phone stops booting after the white Samsung Galaxy S3-logo appears (or when i connect the charging cable, the battery shown doesn't start to turn green)
I can enter the discovery mode:
"E: failed to mount /system (Invalid argument)
can't mount '/system' (invalid argument)
E: failed to mount /system (Invalid argument)"

The bad thing about this problem is: I need to get my photos and contact datas/ numbers. Unfortunately i didnt do a backup before. Moreover the needed data have been created in the last 14 days, when i was on a journey and couldn't do a backup.

Is there a way to get my data from the phone to my PC or USB or external SD?
The phone is not rooted, USB-debugging is not activated. I changed the battery, but that doesn't seem to be the problem.
Is it possible to flash the newest software via Odin without deleting my data (so firmware/ system data only)


Thanks for your help!

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by meghan03
31 minutes ago
Last post by benjamin71
3 hours ago
Last post by quincy.lockman
34 minutes ago
mt6575 bricked
Started by vlemke
Last post by eldred.keeling
2 hours ago
mt6575 bricked
Started by zroob
Last post by vmayert
4 hours ago
Last post by ghackett
4 hours ago
Last post by ikunze
4 hours ago
Last post by bryan
4 hours ago
Last post by zboehm
1 hour ago