Samsung galaxys5 trying to instal old software

Why is my Samsung Galaxy trying to instal version 4.21.1.150131 software when it went from kit kat 4.4 to lollipop 5.0.2 a couple of days agu?

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by frami.archibald
1 hour ago
Last post by jorge.morissette
3 hours ago
Last post by kuhlman.edythe
1 hour ago
Last post by koss.rhoda
27 minutes ago
Last post by kbernhard
4 hours ago
Last post by iveum
4 hours ago
Last post by vhyatt
2 hours ago
Last post by westley.carter
4 hours ago
Last post by moses99
1 hour ago
Help please...
Started by zwalker
Last post by vilma.vandervort
1 hour ago
Last post by kali81
3 hours ago
Last post by meredith.fadel
3 hours ago