Windows Says unknown device when plugging in Samsung Galaxy s3, How To Fix?

Today i plugged in my Samsung Galaxy s3 with a USB cable to the computer windows saw the phone and gave me the choices of what i wanted. I said Open phone to go through files or what its called. But then it just came up with an empty folder. so i thought strange. So i pulled out the cable and put it back in. And then it just said Unknown Device. My phone charges but other than that nothing happens on the phone. There is no USB menu on the phone. Even the phone dosent think its connected other than its charging. What i tried:
Taking out battery, sim card and micro usb card for 1 minute and putting it all in again. Diddent work.
Started the phone in safe mode. Diddent work,
Starting the phone in download mode. Diddent Work.
Using a toothpick to press the little "tung" in the usb hole upwards. Diddent work.
Tried using *#7284# and changing stuff there. Diddent work,
Tried Using *#0808# to change settings there. Diddent work.
Tried starting the phone with the cable in. Diddent work.
Tried uninstalling everything Samsung Kies and drivers. Then putting in the phone in hopes that windows would install drivers for it. Diddent work.
Installed Everything kies again to use those drivers. Diddent work.
Tried using 3 different cables. Diddent Work.
Tried Blowing hard into the usb hole. Diddent Work.
Tried changing USB port and tried using USB 3.0 ports. Diddent Work.

So any other good advices to try?

Thanks

Show Accepted Answer

Guest Quick Reply (No URL, BBcode or HTML)

Last post by rosa19
3 hours ago
Last post by bell.marks
2 hours ago
Last post by lueilwitz.eli
4 hours ago
Last post by ahaag
3 hours ago
Last post by cristobal63
2 hours ago
Last post by kcummings
3 hours ago
Last post by samir36
3 hours ago
Last post by grant.michele
2 hours ago
Last post by ron.quitzon
43 minutes ago
Last post by rcummerata
1 hour ago
Last post by hwyman
4 hours ago
Last post by oconnell.jaida
1 hour ago
Last post by schimmel.ivy
2 hours ago